Miscellaneous Eyeglass and Isilon Configuration

Miscellaneous Eyeglass and  Isilon Configuration Tech Tips










Message “Error retrieving licenses” when accessing the Eyeglass webpage - Published

PUBLISHED: http://support.superna.net/hc/en-us/articles/203665435


Possible Cause: Eyeglass sca service is not running


Troubleshooting Steps:

  1. ssh to the Eyeglass appliance

  2. check whether the Eyeglass sca service is running

dseyeglasstest:~ # service sca status

sca.service - LSB: Run the SCA

  Loaded: loaded (/etc/init.d/sca)

  Active: inactive (dead) since Thu 2014-12-04 19:24:14 UTC; 1h 32min ago

 Process: 8304 ExecStop=/etc/init.d/sca stop (code=exited, status=0/SUCCESS)

 Process: 8272 ExecStart=/etc/init.d/sca start (code=exited, status=0/SUCCESS)


Dec 04 19:24:13 dseyeglasstest systemd[1]: sca.service: control process exited, code=exited status=1

Dec 04 19:24:13 dseyeglasstest systemd[1]: Unit sca.service entered failed state.

Dec 04 19:24:13 dseyeglasstest systemd[1]: Starting LSB: Run the SCA...

Dec 04 19:24:13 dseyeglasstest sca[8272]: Already started

Dec 04 19:24:13 dseyeglasstest systemd[1]: Started LSB: Run the SCA.

Dec 04 19:24:14 dseyeglasstest sca[8304]: Not running




  1. If status shows Active:inactive, it means the sca service is not running.  Then restart the sca service


dseyeglasstest:~ # service sca start



OneFS error joining Active Directory.


Open Cluster Management - Access Management - Active Directory.

Use correct Domain Name and credentials. Join results in error:


Error #1: Clock skew (18120) is too large: Invalid argument


Solution:

ssh to OneFS.


AT-Isilon1-1# isi_classic auth ads time --sync --domain=internal.superna.net

Successfully synced cluster time with the dc.

AT-Isilon1-1#


Error_Clock_skew_on_OneFS.JPG


Join Active Directory.


Join_AD.JPG



About Eyeglass


Description:

What Eyeglass version do I have? How do I update to the newest version?


Solution:

Package information is available in About Eyeglass - Contact Us tab.

Use Eyeglass Main Menu-Settings to check any available updates.




Add Managed Device - Published

http://support.superna.net/hc/en-us/articles/203712575-Message-Error-Plugin-could-not-handle-request-when-adding-an-Isilon-cluster


http://support.superna.net/hc/en-us/articles/203712605-Add-Managed-Device-window-is-blank


Message “Error Plugin could not handle request…” when adding an Isilon cluster.


Problem:

The IP address entered belongs to an Isilon cluster that is already provisioned in Eyeglass.  

Solution:

There is no need to add each node of the same cluster to an Eyeglass server. Eyeglass recognizes that the IP address you entered belongs to a cluster already managed by Eyeglass.




Add Managed Device window is blank



Problem:

No Isilon Discovery license is loaded.  


Solution:

Load the Eyeglass license from the Manage Licenses window.  Once license is loaded, the fields required to provision the Isilon cluster will be displayed.




Eyeglass Jobs Management and Monitoring








Problems:

  1. Cannot select a zone to replicated

  2. Not able to configure a custom job, all checkboxes are disabled


Solution:

Eyeglass handles nfs export and smb share replication. No zone replication.

If a share or an export is already configured by another job then it is no longer available for selection.








Q: What does it mean when Job has error status but audit succeeded?

A: Job has not been run successfully. See Alarms window for detailed error information. All  shares and exports configured for the job are already replicated successfully (from previous run).






Q: What does it mean when Job has OK status but audit skipped?

A: Job has been run and there is no auditable objects (shares and exports) configured for this job.



Message “AEC_FORBIDDEN” for Eyeglass Configuration Replication Job - Published

PUBLISHED: http://support.superna.net/hc/en-us/articles/203474319


Problem:

Eyeglass configuration replication Job fails with error “AEC_FORBIDDEN…..”.


Possible Cause:

Isilon provisioned in Eyeglass with user who does not have minimum required privileges.


Troubleshooting Steps:

  1. Cross reference the permissions of the Isilon OneFS user that is used in Eyeglass provisioning with Minimum Required Privileges documented here: support.superna.net.

  2. If the OneFS user does not have the required privileges, update the user privileges in OneFS.  The next Eyeglass configuration replication job will be based on these updated privileges.

  3. If the OneFS user has the minimum required privileges, double check the OneFS user privileges from the Isilon command line to ensure that they are set as required.